Difficulty building Nettle

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Difficulty building Nettle

Joshua Job
Hello all,

I'm attempting to set up the ability to use an IJulia environment with the kernel operating on my university's cluster. I believe this should be possible, except that thus far I have been unable to build Nettle properly. The gist linked below is the message I get. It appears the version of gcc isn't the same as the one I have in my regular shell environment but is instead the default --- I've added a line like "source gccsetup.sh" to my .bashrc which switches from the default (gcc 4.4.7) to gcc 4.8.1. Is there any way to change the gcc used by Pkg during the build process?

https://gist.github.com/joshjob42/3a3c792467086078af81

Thanks for your help!
-Josh.


Reply | Threaded
Open this post in threaded view
|

Re: Difficulty building Nettle

Joshua Job
For anyone who may have issues in the future, you can simply add

@checked_lib nettle "/path/to/libnettle.so"

in .julia/v0.3/Nettle/deps/deps.jl regardless of where you built nettle.


On Wednesday, September 3, 2014 10:23:51 PM UTC-7, Joshua Job wrote:
Hello all,

I'm attempting to set up the ability to use an IJulia environment with the kernel operating on my university's cluster. I believe this should be possible, except that thus far I have been unable to build Nettle properly. The gist linked below is the message I get. It appears the version of gcc isn't the same as the one I have in my regular shell environment but is instead the default --- I've added a line like "source gccsetup.sh" to my .bashrc which switches from the default (gcc 4.4.7) to gcc 4.8.1. Is there any way to change the gcc used by Pkg during the build process?

<a href="https://gist.github.com/joshjob42/3a3c792467086078af81" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgist.github.com%2Fjoshjob42%2F3a3c792467086078af81\46sa\75D\46sntz\0751\46usg\75AFQjCNFrYAtfTpzsEzQkgDH3L9fBSgWoSA';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgist.github.com%2Fjoshjob42%2F3a3c792467086078af81\46sa\75D\46sntz\0751\46usg\75AFQjCNFrYAtfTpzsEzQkgDH3L9fBSgWoSA';return true;">https://gist.github.com/joshjob42/3a3c792467086078af81

Thanks for your help!
-Josh.


Reply | Threaded
Open this post in threaded view
|

Re: Difficulty building Nettle

Zahirul ALAM
I found no such file. in the specified folder I have build.jl

On Thursday, 4 September 2014 12:50:25 UTC-7, Joshua Job wrote:
For anyone who may have issues in the future, you can simply add

@checked_lib nettle "/path/to/libnettle.so"

in .julia/v0.3/Nettle/deps/deps.jl regardless of where you built nettle.


On Wednesday, September 3, 2014 10:23:51 PM UTC-7, Joshua Job wrote:
Hello all,

I'm attempting to set up the ability to use an IJulia environment with the kernel operating on my university's cluster. I believe this should be possible, except that thus far I have been unable to build Nettle properly. The gist linked below is the message I get. It appears the version of gcc isn't the same as the one I have in my regular shell environment but is instead the default --- I've added a line like "source gccsetup.sh" to my .bashrc which switches from the default (gcc 4.4.7) to gcc 4.8.1. Is there any way to change the gcc used by Pkg during the build process?

<a href="https://gist.github.com/joshjob42/3a3c792467086078af81" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgist.github.com%2Fjoshjob42%2F3a3c792467086078af81\46sa\75D\46sntz\0751\46usg\75AFQjCNFrYAtfTpzsEzQkgDH3L9fBSgWoSA';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgist.github.com%2Fjoshjob42%2F3a3c792467086078af81\46sa\75D\46sntz\0751\46usg\75AFQjCNFrYAtfTpzsEzQkgDH3L9fBSgWoSA';return true;">https://gist.github.com/joshjob42/3a3c792467086078af81

Thanks for your help!
-Josh.


Reply | Threaded
Open this post in threaded view
|

Re: Difficulty building Nettle

Joshua Job
You have to create it. Though, my IJulia notebook seems to be failing for a new reason (which doesn't give a reason why, but I don't *think* it's Nettle causing the problem).

On Thursday, September 4, 2014 3:10:04 PM UTC-7, Zahirul ALAM wrote:
I found no such file. in the specified folder I have build.jl

On Thursday, 4 September 2014 12:50:25 UTC-7, Joshua Job wrote:
For anyone who may have issues in the future, you can simply add

@checked_lib nettle "/path/to/libnettle.so"

in .julia/v0.3/Nettle/deps/deps.jl regardless of where you built nettle.


On Wednesday, September 3, 2014 10:23:51 PM UTC-7, Joshua Job wrote:
Hello all,

I'm attempting to set up the ability to use an IJulia environment with the kernel operating on my university's cluster. I believe this should be possible, except that thus far I have been unable to build Nettle properly. The gist linked below is the message I get. It appears the version of gcc isn't the same as the one I have in my regular shell environment but is instead the default --- I've added a line like "source gccsetup.sh" to my .bashrc which switches from the default (gcc 4.4.7) to gcc 4.8.1. Is there any way to change the gcc used by Pkg during the build process?

<a href="https://gist.github.com/joshjob42/3a3c792467086078af81" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgist.github.com%2Fjoshjob42%2F3a3c792467086078af81\46sa\75D\46sntz\0751\46usg\75AFQjCNFrYAtfTpzsEzQkgDH3L9fBSgWoSA';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgist.github.com%2Fjoshjob42%2F3a3c792467086078af81\46sa\75D\46sntz\0751\46usg\75AFQjCNFrYAtfTpzsEzQkgDH3L9fBSgWoSA';return true;">https://gist.github.com/joshjob42/3a3c792467086078af81

Thanks for your help!
-Josh.